2 din android per alfa 147 2004 distinctive

mirco79

Nuovo Alfista
2 Gennaio 2017
201
1
16
il video lo fatto a macchina in moto.
il comportamento è uguale sia se giro solo per accendere il quadro sia se metti in moto.
anche dopo una sosta lunga tipo una notte intera se giro su mar non fa il boot loading ma compare subito la home appena accendo dal tasto power.
 

mirco79

Nuovo Alfista
2 Gennaio 2017
201
1
16
a rieccomiiiiiiii hihihihihihihihihi
aggiornamento su questa autoradio
partiamo
essendo molto pignolo e diciamo anche un po cocciuto sul funzionamento di un sistema android in tutto questo tempo ho fatto credo tutte le prove possibili e immaginabili per capire se deve o non deve fare il boot loading quando l'autoradio viene acceso dopo che il mezzo e stato spento e se tutto il collegamento iso autoradio iso macchina sia apposto..
la risposta credo sia,come tutti voi mi avete confermato,che questi 2 din android tralasciando la parte software android fa il boot loading completo solo alla prima accensione dopo il PRIMO collegamento fisico col mezzo,successivamente tutto il sistema rimane caricato in una sua memoria tampone facendo in modo che l'autoradio sia pronto appena lo si accende e cosa molto importante mantiene tutti i satelliti caricati allo stato dell'ultimo spegnimento impiegando meno di 5 secondi per ricaricare sia l'interfaccia gps sia i satelliti disponibili.
non perdo le memorie data ora e rimane tutto come io imposto,
allo spegnimento lui cessa tutti i servizi attivi passando in modalità off e si mette a dormire finio a quando no lo si riaccende caricando la memoria tampone in meno di un secondo e riattivando tutti i servizi come sono stati lasciati prima dello spegnimenti e che comunque non si può definire spegnimento ma "sospensione"attiva secondo il mio punto di vista.
quindi dopo molte incertezze sul reale collegamento e sul funzionamento boot loading compreso si arriva a capire che effettivamente il firmware presente sul sistema che gestisce la parte hrdware dell'autoradio,la famosa MCU,non è,se vogliamo dire intelligentemente,programmata per fare un boot loading,quindi un totale caricamento sia software che hardware della sorgente con tutto il suo contenuto ma è studiato per farlo fare solo al primo collegamento fisico all'alimentazione correttamente installata e fino allo stabilizzarsi di tutta la sua parte hardware nel corpo elettronica auto/autoradio.
quindi se qualcuno inizia come me ad avere dubbi sul boot loading prima di sbattere la testa con collegamenti o altro be toglieteveli perchè il boot loading totale
lo fa solo la prima volta che lo si collega,il resto lo fa la memoria tampone e il firmware caricato.
ecco le prove fatte con collegamento sotto chiave;
piccola premessa
sulla mia alfa 147 ho il sottochiave sulla iso macchina quindi non ho utilizzato nessun passaggio cavi da accendisigari o altre parti e soprattutto quel sotto chiave è protetto dal circuito BC.
sono state fatte tutte le verifiche sulla mia iso macchina che avendo il canbus per la gestione dell'impiato originale installato di serie su dubitava fortemente della presenza di un sotto chiave su quel connettore.
i collegamenti canbus anche se presenti vengono utilizzati solo dal suo impianto originale,quindi o il suo autoradio alfa o il sistema nav sempre originale alfa,con un autoradio aftermarcket cina o non cina,a patto che non sia progettato fisicamente per la linea canbus,i fili canbus pur presenti sulla iso auto non vanno ad interagire sulla iso autoradio,i pin di collegamento restano vuoti lato autoradio quindi nessun segnale,in pratica e come se non ci fossero e sono solo due il resto dei fili presenti sulla iso auto sono rispettivamente,anche se in colori differenti rispetto ad un ISO standard ,con segnali e tensioni conformi allo standard universale quindi abbiamo
iso lato autoradio
nero
rosso
giallo
blu
arancio
ISO lato macchina(che mi ha fatto impazzire :) prima di capire come è composto)
nero
rosso
verde/blu (il sotto chiave)
grigio/bianco(amp antenna)
arancio(illuminazione)non c'e' perche presente o sul bizona o sul devio luci o su qualsiasi altra parte che comanda l'illuminazione del mezzo e non predisposto sulla iso
rosa/bianco canbus
rosa verde canbus
come tutti giustamente avete detto è ripetuto(ma io sono un po testardo e voglio capire come funzionano le cose e il reale motivo soprattuto perche l'iso in dotazione aveva questi cavi invertiti) c'e' stata solo la necessità di inverire il rosso e il giallo sulla iso autoradio in modo da consentire allo stesso l'utilizzo della memoria tampone e cosa importante che volevo e credo di aver capito,la gestione della MCU con questa memoria tampone spiegando il non boot loading alle successivi accensioni e lo "spegnimento fisico"che pur facendolo non è uno spegnimento ma solo una sospensione dei servizi attivi sul sistema e il mantenimeto della memoria tampone sia ardware che software.
il tutto collegato sotto chiave perchè a me va benissimo così visto che non uso mai l'autoradio a macchina spenta.
passiamo alle prove con sorgente collegata(per sorgente intendo l'autoradio) e strumento per misurare assorbimenti:
primo collegamento fisico autoradio/auto
alla prima accensione l'autoradio,carica il sistema,quindi boot loading totale inclusa MCU di gestione hardware e sitema android con relative app e servizi in esecuzione;
una volta caricato tutto l'autoradio gestito dalla MCU sul lato hardware deve stabilizzarsi,quindi deve rintracciare tutte le perifeiche(usb esterne escluse)fisiche presenti,che sono:
perifierica GPS (installata fisicamente e non aggiunta come perifierica opzionale)
periferica bluethoot (installata fisicamente e non aggiunta come perifierica opzionale)
periferica WIFI (installata fisicamente e non aggiunta come perifierica opzionale)
modulo 3G (installato fisicamente e con periferica simcard opzionale ma in dotazione collegata)
e tutto il resto dell'hardware presente al suo interno.
il processo di stabilizzazzione di tutto l'hardware presente richiede circa 30 minuti immagazzinando tutto nella memoria tampone
questo procedimento stabillizzatore sorgente alla prima messa in funzione ha un assorbimento in Ampere molto elevato,arrivando anche ad assorbere 12 14ah
una volta concluso il processo tutti gli assorbimenti calano perchè la sorgente è alimentata,tutti i componenti hardware sono caricati nella memoria tampone portando la sorgente,in funzione,ad assorbire a macchina o quadro accesa 0.68ah
a macchina spenta quadro spento e sorgente spenta 0.00 0.01ah
giusto quello che serve per mantenere la memoria tampone e il sistema caricato.
non contento per verificare se effettivamente il comportamento è giusto in base a tutti i test fatti con strumento alla mano si è fatta la prova del "9"
staccando fisicamente la sorgente;
lasciarla riposare in modo che tutta la memoria tampone si resettasse
far resettare tutto l'hardware e farlo "raffreddare"
dare il tempo al mezzo di chiudere il suo circuto lasciando attivo solo il carico necessario alla strumentazione di bordo staccando tutto il resto dei servizi,luci cortesia airbag ecc ecc e ricollegare successivamente la sorgente,la stessa richiede nuovamente la stabilizzazzione del sitema.
questo mi conferma che al primo avvio la sorgente assorbe quello che vuole fino allo stabilizzarsi
una volta stabilizzato,caricato la memoria tampone e tutti i componenti hardware sono pronti e attivi al 100% la sorgente spenta con mezzo spento quadro spento chiave disinserita ma anche inserita cessa i servizi in esecuzione ma mantiene sia l'hardware che il sistema android caricato nella memoria tampone andando ad assorbire solo 0.00 0.01ah.

tutto questo che vi ho elencato e che è stato testato da me serviva solo per capire come questi sistemi android vengono gestiti si a livello software ma soprattutto a livello hardware che viene gestito dalla MCU che non ha nulla a che vedere col sistema operativo android.

allo stato attuale e dopo aver capito il funzionamento devo dire che il sistema 2 din che io ho,ma credo funzionino tutti così,è gestito molto intelligentemete
sia lato hardware che software ciucciando le giuste correnti o quasi niente per mantenere sempre tutto attivo e memorizzato precisando anche che il fattore memorizzato nella memoria tampone riguarda,ed è un dato di fatto e verificato,solo la parte hardware che viene caricata dalla MCU e passata in memoria tra queste anche il piccolo circuito integrato che gestisce data e ora NON presi nel dal GPS ne dal servizio dati ma solo dalla sorgente.

spero di aver fatto cosa gradita a dilungarmi su questo argomento entrando nello specifico.
a breve inizierò a testare la sorgente erisin es5092y nel totale funzionamento inserendo foto descrizione e pareri sempre personali del sistema.
per ora mi fermo quì
:drive) :drive) :drive) :bravo)
 

mirco79

Nuovo Alfista
2 Gennaio 2017
201
1
16
da qualche giorno sto testando l'autoradio in oggetto
che dire sembra veramente fatto bene anche se da qualche giorno mi sto soffermando sull'impostazione del logo che pur impostandolo sto logo riesco a vederlo solo e dico solo dopo che impostato mi fa fare il reboot caricando il sistema e visuallizando il logo.
alle successive accensioni sto logo non compare mai.
c'e' un modo per farlo visualizzare ad ogni accensione dell'autoradio o bisogna rassegnarsi a vederlo solo una volta visto che quando lo spegne va in sospensione,o solo quando lo si reimposta o si stacca la batteria dell'auto o l'autoradio stesso?
 

mirco79

Nuovo Alfista
2 Gennaio 2017
201
1
16
abbandonato il fattore logo del mezzo non vuole saperne,me lo fa vedere solo dopo un riavvio totale,sono passato al reparto 3G visto che ho il modem incluso

ora chiedo aiuto
oggi ho inserito una nuova e per la prima volta sim dati traffico voce ed sms sulla mia autoradio che è questa come da primo post
http://www.ebay.it/itm/7-doppio-2DIN-An ... Sws6ZaA9sQ

il servizio dati funziona alla grande senza problemi.
visto che c'ero ho inviato una chiamata dal mio cellulare sulla sim inserita nell'autoradio per vedere cosa succede
l'autoradio ha iniziato a squillare ma non mi fa rispondere perchè non apre nessuna app o servizio chiamate quindi chiudo la chiamata.
nel menù a tendina mi compare la chiamata persa con due opzioni "richiama" e "messaggio"
clicco su messaggio e non mi apre nulla.
clicco su richiama e parte la chiamata verso il mio cellulare.
non ho risposto alla chiamata sul mio cellulare perchè cercavo di capire quale servizio stesse usando per inviare la chiamata,non trovando nulla parte la segreteria telefonica sul mio cellulare e non potendo chiudere la chiamata inviata dall'autoradio sono stato costretto a spegnere l'autoradio stesso dopo che si era attivata la segreteria.
chiamando la segreteria telefonica dal mio cellulare riesco ad ascoltare perfettamente la chiamata inviata dall'autoradio con la mia voce fino al momento dello spegnimento dello stesso.
ora vorrei sapere che applicazione dovrei installare per poter usufruire delle chiamate vocali e per i normali messaggi di testo visto che riesco ad inviare e a ricevere chiamte e anche i messaggi?
 
Top